Back to overview
Degraded

Navigating the Global AWS Outage

Oct 20 at 08:01am IST
Affected services
chiragganguli.com
Blogs Node
APIs and CDNs
Research Node
Utilities Node

Resolved
Oct 21 at 09:21am IST

And... we're back! The digital storm has passed, and the sun is shining on our servers once again.
It turns out the internet just needed a bit of a coffee break yesterday. Our cloud provider (AWS) has worked their magic, and we've successfully moved everything back from our trusty backup servers to the main stage.
This means all services have been restored to their usual zippy, optimal performance. The hamsters powering the site have been given a pep talk, and we're officially back to light speed.
Thanks for hanging in there with us while we wrangled the gremlins. Happy browsing!

Updated
Oct 21 at 05:06am IST

Overview
This is an update regarding the recent global Amazon Web Services (AWS) outage. As of this morning, AWS has announced that their services have been restored.

Current Status
Our website continues to operate on our stable backup servers.
Our team is now closely monitoring the performance and stability of the restored AWS infrastructure. We are proceeding with caution to ensure the issues are fully resolved before we transition traffic back to our primary servers.

Impact on Users
For now, users may continue to experience slightly slower load times as we are still running on our backup systems. We are prioritizing stability to prevent any further disruptions.

Next Steps
We will continue this monitoring phase to validate the health of the AWS environment. Once we are confident in its stability, we will begin the process of migrating back to our primary infrastructure.
We will post another update once that process is complete and normal site performance has been fully restored. We thank you for your continued patience.

Created
Oct 20 at 08:01am IST

Overview
This is a notice to all our users regarding the current performance and availability of our website. A global outage affecting Amazon Web Services (AWS), our primary cloud provider, is currently impacting services worldwide.

Current Status
Our team has successfully failed over to our backup servers to keep the website operational.
The site is currently online and accessible.

Impact on Users
While the site is available, it is running under a reduced load capacity. Users may experience the following:
• Slower Load Times: Pages and services may take longer to load than usual.
• Intermittent Errors: There is a possibility of intermittent errors during peak usage.
We are actively managing the server load to ensure the best possible availability for everyone.

Next Steps
We are closely monitoring the situation with AWS and will restore full service as soon as their primary systems are back online. We appreciate your patience and understanding during this time.

Thank you.